Absoft User Forum

Support => Macintosh => Topic started by: Yoshihiko Haramura on June 07, 2022, 10:25:06 PM

Title: link error ld: framework not found QtGui
Post by: Yoshihiko Haramura on June 07, 2022, 10:25:06 PM
I got error "ld: framework not found QtGui" when built as an AWE Application. Build was completed and the application runs correctly when built as a Terminal Application.
My system is: Absoft ProFortran 21.0.2, IDE Version 2.2.10, Qt version 5.12.3
                     macOS Monterey 12.4, Intel Core i5
                     Xcode ver.13.4.1 (13F100) has been installed and activated.
Tell me what to do ?
Title: Re: link error ld: framework not found QtGui
Post by: forumadmin on June 08, 2022, 11:23:33 AM
You might want to email Absoft Support directly on this one, but do you get the same error when you try to build any AWE project? Does it occur with the AWE_BarChart example located in your /Applications/Absoft21.0/examples folder?


The QtGui framework the linker is complaining about should be located in your /Applications/Absoft21.0/Frameworks folder. If you open /Applications/Absoft21.0/Frameworks in the macOS Finder, do you see a folder named QtGui.framework?