gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
1608 Posts in 532 Topics by 776 Members - Latest Member: evvaletov September 28, 2022, 04:05:12 PM
*
gfx* Home | Help | Search | Login | Register | gfx
gfx
Absoft User Forum  |  Support  |  Macintosh  |  Fx3 Debugger acting up on Yosemite (10.10.1)
gfx
gfxgfx
 

Author Topic: Fx3 Debugger acting up on Yosemite (10.10.1)  (Read 1690 times)

christopherpurcell

  • Newbie
  • *
  • Posts: 10
Fx3 Debugger acting up on Yosemite (10.10.1)
« on: January 01, 2015, 03:39:13 PM »
Today I tried to use the Fx3 debugger for the first time since upgrading to Yosemite on my iMac.
When the debugger is launched on a freshly built Fortran code,  from Absoft Tools (Absoft Pro Fortran 11.0.5) it fails with the following error message:

Error: Unable to load program: No mach task port for pid 5700.
Error: Command requires a live process

Debugging worked fine in the past, so this appears to be something new. Advice on fixing this would be appreciated.

paj

  • Newbie
  • *
  • Posts: 7
Re: Fx3 Debugger acting up on Yosemite (10.10.1)
« Reply #1 on: January 02, 2015, 07:55:26 AM »
I'm surprised you got AbsoftTools for V11.0 to work at all on Yosemite. You must not have upgraded Xcode.

V11.0 is not supported on Yosemite due to changes in Xcode. Fx3 won't work at all. You'll need to upgrade to Pro Fortran 2015 (V15.0).

christopherpurcell

  • Newbie
  • *
  • Posts: 10
Re: Fx3 Debugger acting up on Yosemite (10.10.1)
« Reply #2 on: January 02, 2015, 10:30:06 AM »
I am running the latest Xcode 6.0, but I don't use it for Fortran.

The Absoft Tools IDE 2.0 for Absoft Fortran 11.0.5 compiles Fortran codes just fine on Mac OSX10.10.1.

My only issue is the Fx3 debugger, which fails when opening an executable. I tried playing with code signing the F3X app, but that didn't help.
 

Absoft User Forum  |  Support  |  Macintosh  |  Fx3 Debugger acting up on Yosemite (10.10.1)
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!