Absoft User Forum

Support => Macintosh => Topic started by: mdegraef on April 16, 2012, 08:54:52 AM

Title: HDF5 version 1.8.8 does not work with Absoft compiler 11.1.3
Post by: mdegraef on April 16, 2012, 08:54:52 AM


I am running Absoft Pro Fortran 11.1.3 on a Mac with OS X 10.7.3.  This Absoft installation comes with the library files for HDF5 version 1.8.5, and I can compile programs that call HDF5 routines without any problems.  I would like to upgrade to HDF5 version 1.8.8, and suddenly nothing compiles anymore (I downloaded the library files from the hdf5 group web site and installed them in the same locations as the original 1.8.5 files)...  The compiler complains that it can not find the HDF5 module files, even though they have been placed in the same locations as the 1.8.5 files.  The only difference between the two installations is that the *.mod files in 1.8.8 have lowercase filenames, whereas the ones in the original 1.8.5 installation have uppercase *.mod file names...  I have tried every combination trying to get the short program below to compile, and I can't get it to work with 1.8.8; no problems with 1.8.5....

program MXAlib

use HDF5
!use hdf5

integer   :: majnum, minnum, relnum, error

!call h5get_libversion_f(majnum, minnum, relnum, error)

call H5GET_LIBVERSION_F(majnum, minnum, relnum, error)

write (*,*) 'Major number ',majnum
write (*,*) 'Minor number ',minnum
write (*,*) 'Release number ',relnum
write (*,*) 'Error code ',error

end program MXAlib

When I compile with 1.8.5 files, no problem; when I switch to 1.8.8, I get the following error message:

Line 14  ERROR  "HDF5" is specified as the module name on a USE statement, but the compiler cannot find it.

I've tried all combinations of uppercase/lowercase settings in the project options, to no avail...

Any suggestions at all ?  If I can't get 1.8.8 to work with the Absoft compiler, I'm going to have to drop the Absoft compiler altogether...which I would prefer not to do...

Title: Re: HDF5 version 1.8.8 does not work with Absoft compiler 11.1.3
Post by: forumadmin on April 16, 2012, 11:51:12 AM
My guess is that you downloaded binaries built for some other compiler. The modules will not be compatible as they are specific to the individual compiler. Contact support@absoft.com and they will be able to help you.