gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
1619 Posts in 535 Topics by 781 Members - Latest Member: chekyl43 January 27, 2023, 03:17:24 PM
*
gfx* Home | Help | Search | Login | Register | gfx
gfx
Absoft User Forum  |  Support  |  General  |  Absoft 9+ not compatible with Fortran 77?
gfx
gfxgfx
 

Author Topic: Absoft 9+ not compatible with Fortran 77?  (Read 6811 times)

jregan5

  • Newbie
  • *
  • Posts: 20
Absoft 9+ not compatible with Fortran 77?
« on: February 22, 2008, 02:55:23 PM »
I have just been told that Absoft Fortran versions 9 and 10 (and presumably future versions) are not necessarily backward compatible with Fortran 77 source code, and that F77 code compiled with these versions of Fortran may not compile properly. Can anyone confirm this for me?

Mike Linacre

  • Sr. Member
  • ****
  • Posts: 259
Re: Absoft 9+ not compatible with Fortran 77?
« Reply #1 on: February 23, 2008, 10:00:20 PM »
Some FORTRAN 77 statements changed the way they functioned when ABSOFT introduced CRAY-FORTRAN compatibility. I particularly experienced problems with EQUIVALENCE statements. Please see my notes at www.winsteps.com/absoft.htm. Some of the bugs may have been fixed in later releases of ABSOFT 9.

Absoft User Forum  |  Support  |  General  |  Absoft 9+ not compatible with Fortran 77?
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!