gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
1617 Posts in 535 Topics by 779 Members - Latest Member: rhoronjeff@comcast.net November 27, 2022, 07:46:29 PM
*
gfx* Home | Help | Search | Login | Register | gfx
gfx
Absoft User Forum  |  Support  |  Windows  |  Problem when compiling a module
gfx
gfxgfx
 

Author Topic: Problem when compiling a module  (Read 6541 times)

mmalbert

  • Newbie
  • *
  • Posts: 4
Problem when compiling a module
« on: November 14, 2007, 08:49:21 AM »
Recently, I move up from ProFortran v7 to ProFortran v10. And I meet a problem for which I really need help because I do not understand it.
 
I try to compile the following module :
      module m_ident
      real*8,allocatable,save :: volu(:)
      end module m_ident
 
With v7, compilation was OK. With v10, I obtain the message :  "LINK : fatal error LNK1561: entry point must be defined"

Thank you for your help

Mike Linacre

  • Sr. Member
  • ****
  • Posts: 259
Re: Problem when compiling a module
« Reply #1 on: November 14, 2007, 09:21:08 PM »
Try changing the last line from:
             end module m_ident
to:
             end module
 
 

mmalbert

  • Newbie
  • *
  • Posts: 4
Re: Problem when compiling a module
« Reply #2 on: November 15, 2007, 02:53:15 AM »
Thank you for your suggestion. I try it, without success !!!

My problem is very strange : there is no syntax error and using the compiler of Absoft editor is quite simple.

If anyone has another suggestion, it is welcome !

Michel Malbert

Mike Linacre

  • Sr. Member
  • ****
  • Posts: 259
Re: Problem when compiling a module
« Reply #3 on: November 15, 2007, 03:25:42 AM »
Mmalbert - please check which link-editor you are using.
Absoft used to use lnk.exe - now it uses link.exe
If you have lnk.exe on your computer, try using that instead.

Absoft User Forum  |  Support  |  Windows  |  Problem when compiling a module
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!