gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
1617 Posts in 535 Topics by 779 Members - Latest Member: rhoronjeff@comcast.net November 27, 2022, 09:50:51 PM
*
gfx* Home | Help | Search | Login | Register | gfx
gfx
Absoft User Forum  |  Support  |  Windows  |  Installation Issue
gfx
gfxgfx
 

Author Topic: Installation Issue  (Read 5876 times)

jregan5

  • Newbie
  • *
  • Posts: 20
Installation Issue
« on: November 30, 2007, 02:01:28 PM »
I'm trying to install Absoft Fortran 10 on Windows XP Pro 64. I can only install software as admin. I installed the software as admin and ran it and everything seems fine. When I run it under my user account, however, I get all sorts of errors, such as:
  • The first time I opened the Developer Tools after install (under the user account) I got a message box that said "Cannot locate the installed Absoft product directory, or the directory specified is invalid." It let me locate the bin directory myself, however, and I didn't get that box again.
  • The tips box that opens when I open the Developer Tools says "Tips file does not exist in the prescribed directory." Not a major problem in itself, but it is a symptom of the greater issue.
  • In the Developer Tools, when I try to open a fortran source file, I get a message box that says "Unable to locate Language Resources." It asks me to locate them myself, but when I select the appropriate folder, I still don't get syntax highlighting (ie: it doesn't seem to accept the folder I've chosen as the location of the language resources). In addition, I get this same message every time I open a file.
  • And the big problem: when I try to compile a program, I get an "Unable to obtain license: License not found" error.

I've tried (as admin) changing the permissions of the Absoft directory to "Full Control" for "Everyone," but that didn't do the trick.

Any ideas?

Mark Coxhead

  • Jr. Member
  • **
  • Posts: 82
Re: Installation Issue
« Reply #1 on: December 05, 2007, 03:38:18 AM »
On the issue of the message "Unable to obtain license: license not found" I did encounter this last September when rebuilding the MRWE with makefiles etc, after just installing ABSOFT version 10.   

On that occasion the reason was because I was not using the "Development Command Prompt" and was using "Command Prompt" which does not have any of the paths setup. 

Go to Start -> Absoft Pro Fortran 10 -> Development Command Prompt (32-bit)   or 64-bit if that is what you want to use.

The above environment contains the paths that are needed to compile code no matter what directory you are in.



Mike Linacre

  • Sr. Member
  • ****
  • Posts: 259
Re: Installation Issue
« Reply #2 on: December 05, 2007, 06:21:56 PM »
Thank you, Mark. It was the "license not found" problem which was the chief reason I haven't upgraded. Didn't know about the "Development Command Prompt". Now to find a way to build that into "shell" calls. Do you think that appending all the environment variable values from the "Development Command Prompt" onto the standard Windows environment variables will work?

Absoft User Forum  |  Support  |  Windows  |  Installation Issue
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!