gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
1568 Posts in 518 Topics by 754 Members - Latest Member: irekzawadzki December 03, 2021, 08:17:32 AM
*
gfx* Home | Help | Search | Login | Register | gfx
gfx
Absoft User Forum  |  Support  |  Windows  |  Problems after upgrade to WIN 7 PRO
gfx
gfxgfx
 

Author Topic: Problems after upgrade to WIN 7 PRO  (Read 3803 times)

Gene

  • Jr. Member
  • **
  • Posts: 56
Problems after upgrade to WIN 7 PRO
« on: July 31, 2013, 10:12:08 AM »
I had Absoft 2012 running OK on my 32 bit machine w/ WIN XP PRO.  After upgrading to WIN 7 PRO 32 bit (on the same machine), when I try to 'rebuild' a project I get an error 'Can Not Generate MakeFile.'

What is puzzling is that the same error occurs on any project I open; BUT the 'MakeFile error' is totally unrelated to any of the Projects I open.  IE, the code the MakeFile is trying to work with is not even in my currently opened project.  The code does exist on my machine; but for whatever reason every Project I open tries to work with this same piece of non-included code with a makefile.

Any thoughts on this appreciated.  I've uninstalled and re-installed Absoft 2012 Pro Fortran but still get the error.  I've got the December 2012 Service Pack installed.

forumadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 321
Re: Problems after upgrade to WIN 7 PRO
« Reply #1 on: July 31, 2013, 11:17:03 AM »
Are you using AbsoftTools? This specific error message, "Can Not Generate Makefile", is not issued by AbsoftTools. I suspect that AbsoftTools cannot create a makefile because the directory is not writable. Did your upgrade archive your existing disk and directory structure? Check to see if you can create any file in the directory.

Gene

  • Jr. Member
  • **
  • Posts: 56
Re: Problems after upgrade to WIN 7 PRO
« Reply #2 on: July 31, 2013, 08:47:37 PM »
Yes, I am using the AbsoftTools interface.  I'll check into whether the SubDirectory is writeable.


Gene

  • Jr. Member
  • **
  • Posts: 56
By changing the Windows 7 'User Account Control Settings' via a 'Slider Bar' to the 'Never Notify' setting, I'm able to now compile with Absoft 2012 as before when I was using WIN XP PRO.

I've also noticed this behavior in another program on another computer, after I upgraded it to Windows 7.  With this other program on the other computer, my ability to do a 'backup' to the hard drive was eliminated; until I changed the 'User Account Control Setting' via the 'slider' to 'Never Notify.'  Now I can do a backup.....

Any thoughts on this issue, with respect to the User Account Control Settings, is appreciated. 

I don't like to use the setting 'Never Notify'.......  but in this case of writing to the hard drive it seems necessary......  how else might this be accomplished???? 

Any feedback is appreciated on this......

Mike Linacre

  • Sr. Member
  • ****
  • Posts: 251
Re: Problems after upgrade to WIN 7 PRO
« Reply #4 on: August 02, 2013, 03:00:12 AM »
Gene, I have encountered this type of problem with other software development packages, so now am permanently logged in as Administrator where this type of thing does not happen.

Gene

  • Jr. Member
  • **
  • Posts: 56
Re: Problems after upgrade to WIN 7 PRO
« Reply #5 on: August 02, 2013, 10:24:13 AM »
Mike- thanks.

In my two cases, I was also an 'Administrator' beforehand; and I still had to set the 'Slider' to 'Do Not Notify.'

Things appear to be OK now with this setting set as previously described.

Best regards


Absoft User Forum  |  Support  |  Windows  |  Problems after upgrade to WIN 7 PRO
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!