gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
1617 Posts in 535 Topics by 779 Members - Latest Member: rhoronjeff@comcast.net December 04, 2022, 08:08:57 PM
*
gfx* Home | Help | Search | Login | Register | gfx
gfx
Absoft User Forum  |  Archive  |  Linux Archive  |  Installing Absoft Pro Fortran 2012 (11.5) on 64 Bit Linux
gfx
gfxgfx
 

Author Topic: Installing Absoft Pro Fortran 2012 (11.5) on 64 Bit Linux  (Read 7470 times)

forumadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 333
Installing Absoft Pro Fortran 2012 (11.5) on 64 Bit Linux
« on: December 12, 2011, 10:19:54 AM »
This post addresses  issues encountered when installing Absoft Pro Fortran 2012 on the latest releases of the 64 Bit Fedora Core, RedHat Enterprise Linux, Open SuSE, Debian, and Ubuntu Linux distributions.


Fedora Core 16 64 bit
Fedora Core 17 64 bit

A default installation of Fedora Core 16 or Fedora Core 17 requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
glibc.i686                          Support for running 32 bit programs
libstdc++.i686                  Support for running 32 bit programs
gcc                                   Support for software development
gcc-c++                           Support for software development
xterm                               Terminal program used by AbsoftTools and Fx3 Debugger
glibc-devel.i686                 Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the yum command to install the package.

1) 32 bit executable support not installed

   Symptom:

     $ af90 t.f
        sh: /opt/absoft11.5/bin/af90fe64: /lib/ld-linux.so.2: bad ELF interpreter:
            No such file or directory
        f90fe failed.

    Fix: install 32 bit glibc

     $ sudo yum install glibc.i686

2) 32 bit libstdc++.so.6 not installed

    Symptom:

      $ af90 t.f
        /opt/absoft11.5/bin/atmod: error while loading shared libraries: libstdc++.so.6:
            cannot open shared object file: No such file or directory
        atmod failed.

   Fix: install 32 bit libstdc++.so.6

        $ sudo yum install libstdc++.i686

3) GCC/G++ and other development tools not installed

    Symptom:

      $ af90 t.f
      sh: as: command not found
      assembler failed.

      $ af90 t.f
      sh: g++: command not found
      link failed.

    Fix: Install GCC and C++ support
 
      $  sudo yum install  gcc   
      $  sudo yum install  gcc-c++

 4) Unable to execute projects inside AbsoftTools

    Symptom:

      An error dialog appears which reads "Could not start "xterm -name "Absoft Tools"... "

    Fix: install xterm program

      $ sudo yum install xterm

 5) Unable to build 32 bit programs

     Symptom:

      $ af90 -m32 t.f
      /usr/bin/ld: cannot find crt1.o: No such file or directory
      /usr/bin/ld: cannot find crti.o: No such file or directory
      /usr/bin/ld: skipping incompatible /usr/lib64/libpthread.so when
                    searching for -lpthread

     Fix: install 32 bit development libraries

      $ sudo yum install glibc-devel.i686


RedHat Enterprise Linux 6.2 64 bit
RedHat Enterprise Linux 6.3 64 bit
A default Software Development Workstation installation of RedHat 6.2 and 6.3 requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
glibc.i686                          Support for running 32 bit programs
libstdc++.i686                  Support for running 32 bit programs
xterm                               Terminal program used by AbsoftTools and Fx3 Debugger
glibc-devel.i686                 Support for building 32 bit programs
                       
Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) Compiler front-end fails to run, no 32 bit executable support

   Symptom:
   
     $ af90 t.f
        sh: /opt/absoft11.5/bin/af90fe64: /lib/ld-linux.so.2: bad ELF interpreter:
           No such file or directory
        f90fe failed.

   Fix: Install 32 bit executable support

     $ sudo yum install glibc.i686

2) atmod fails, missing 32 bit libstdc++.so.6

   Symptom:

   $ af90 t.f
    /opt/absoft11.5/bin/atmod: error while loading shared libraries:
    libstdc++.so.6: cannot open shared object file:
    No such file or directory

   Fix: Install 32 bit libstdc++.so.6

   $ sudo yum install libstdc++.i686

 3) Unable to execute projects inside AbsoftTools

    Symptom:

      An error dialog appears which reads "Could not start "xterm -name "Absoft Tools"... "

    Fix: install xterm program

      $ sudo yum install xterm
 
  4) Unable to build 32 bit programs

     Symptom:

      $ af90 -m32 t.f
      /usr/bin/ld: cannot find crt1.o: No such file or directory
      /usr/bin/ld: cannot find crti.o: No such file or directory
      /usr/bin/ld: skipping incompatible /usr/lib64/libpthread.so when
                    searching for -lpthread

     Fix: install 32 bit development libraries

      $ sudo yum install glibc-devel.i686
 

Open SuSE 12.1 64 bit

A default installation of Open SuSE 12.1 requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
gcc                                      Support for software development
gcc-c++                              Support for software development
gcc-32bit                             Support for building 32 bit programs
gcc-c++-32bit                     Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the zypper command to install the package.

1) Link fails, g++ not found

   Symptom:

    $ af90 t.f
    sh: g++: command not found
    link failed.

   Fix: install g++ (along with the rest of the C development tools)

    $ sudo zypper install gcc-c++

   Explanation:

      We use g++ to perform the link because AWE is written in C++.

2) Unable to build 32 bit programs

     Symptom:

      $ af90 -m32 t.f
        /usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld:
            skipping incompatible /usr/lib64/gcc/x86_64-suse-linux/4.6/../../../libpthread.so
            when searching for -lpthread

     Fix: install 32 bit development support

      $ sudo zypper install gcc-c++-32bit


Debian 6.0.3 64 bit

A default installation of 64 bit Debian 6.0.3 from the Debian GNOME Desktop"Live" DVD requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
lib32stdc++6                    Support for running 32 bit programs
gcc                                    Support for software development
g++                                  Support for software development
gcc-multilib                        Support for building 32 bit programs
g++-multilib                      Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) atmod fails, missing 32 bit libstdc++6

   Symptom:
     
     $ af90 t.f
       /opt/absoft11.5/bin/atmod: error while loading shared libraries:
       libstdc++.so.6: cannot open shared object file: No such file or directory
       atmod failed.
     
   Fix: install 32 bit libstdc++6

     $ sudo apt-get install lib32stdc++6
 
2) GCC/G++ and other development tools not installed

    Symptom:

      $ af90 t.f
      sh: as: command not found
      assembler failed.

      $ af90 t.f
      sh: g++: command not found
      link failed.

    Fix: Install GCC and C++ support

      $ sudo apt-get install gcc
      $ sudo apt-get install g++


3) Building 32 bit program fails

    Symptom:

     $ af90 -m32 t.f

    Fix: install 32 bit development support

     $ sudo apt-get install gcc-multilib
     $ sudo apt-get install g++-multilib
     

Ubuntu 12.04 64 bit

A default installation of Ubuntu 12.04 requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
ia32-libs                         Support for running 32 bit programs
gcc                                 Support for software development
g++                               Support for software development
gcc-multilib                      Support for building 32 bit programs
g++-multilib                      Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) Compiler front-end fails to load, no 32 bit executable support

   Symptom:
 
     $ af90 t.f
       sh: /opt/absoft11.5/bin/af90fe64: not found

   Fix: install 32 bit executable support

     $ sudo apt-get install ia32-libs

2) Link fails, g++ not found

   Symptom:

    $ af90 t.f
    sh: g++: not found
    link failed.

   Fix: install g++ (along with other C development tools)

    $ sudo apt-get install g++

   Explanation:

      We use g++ to perform the link because AWE is written in C++.

3) Building 32 bit program fails

    Symptom:

     $ af90 -m32 t.f
       /usr/bin/ld: cannot find crt1.o: No such file or directory
       /usr/bin/ld: cannot find crti.o: No such file or directory
       /usr/bin/ld: cannot find -lpthread

    Fix: install 32 bit development support

     $ sudo apt-get install gcc-multilib


« Last Edit: January 22, 2013, 07:56:21 AM by forumadmin »

forumadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 333
This post addresses  issues encountered when installing Absoft Pro Fortran 2012 on the latest releases of the 64 Bit Fedora Core, RedHat Enterprise Linux, Open SuSE, Debian, and Ubuntu Linux distributions.


Fedora Core 16 64 bit
Fedora Core 17 64 bit

A default installation of Fedora Core 16 or Fedora Core 17 requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
glibc.i686                          Support for running 32 bit programs
libstdc++.i686                  Support for running 32 bit programs
gcc                                   Support for software development
gcc-c++                           Support for software development
xterm                               Terminal program used by AbsoftTools and Fx3 Debugger
glibc-devel.i686                 Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the yum command to install the package.

1) 32 bit executable support not installed

   Symptom:

     $ af90 t.f
        sh: /opt/absoft11.5/bin/af90fe64: /lib/ld-linux.so.2: bad ELF interpreter:
            No such file or directory
        f90fe failed.

    Fix: install 32 bit glibc

     $ sudo yum install glibc.i686

2) 32 bit libstdc++.so.6 not installed

    Symptom:

      $ af90 t.f
        /opt/absoft11.5/bin/atmod: error while loading shared libraries: libstdc++.so.6:
            cannot open shared object file: No such file or directory
        atmod failed.

   Fix: install 32 bit libstdc++.so.6

        $ sudo yum install libstdc++.i686

3) GCC/G++ and other development tools not installed

    Symptom:

      $ af90 t.f
      sh: as: command not found
      assembler failed.

      $ af90 t.f
      sh: g++: command not found
      link failed.

    Fix: Install GCC and C++ support
 
      $  sudo yum install  gcc   
      $  sudo yum install  gcc-c++

 4) Unable to execute projects inside AbsoftTools

    Symptom:

      An error dialog appears which reads "Could not start "xterm -name "Absoft Tools"... "

    Fix: install xterm program

      $ sudo yum install xterm

 5) Unable to build 32 bit programs

     Symptom:

      $ af90 -m32 t.f
      /usr/bin/ld: cannot find crt1.o: No such file or directory
      /usr/bin/ld: cannot find crti.o: No such file or directory
      /usr/bin/ld: skipping incompatible /usr/lib64/libpthread.so when
                    searching for -lpthread

     Fix: install 32 bit development libraries

      $ sudo yum install glibc-devel.i686


RedHat Enterprise Linux 6.2 64 bit

A default Software Development Workstation installation of RedHat 6.2 requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
glibc.i686                          Support for running 32 bit programs
libstdc++.i686                  Support for running 32 bit programs
xterm                               Terminal program used by AbsoftTools and Fx3 Debugger
glibc-devel.i686                 Support for building 32 bit programs
                       
Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) Compiler front-end fails to run, no 32 bit executable support

   Symptom:
   
     $ af90 t.f
        sh: /opt/absoft11.5/bin/af90fe64: /lib/ld-linux.so.2: bad ELF interpreter:
           No such file or directory
        f90fe failed.

   Fix: Install 32 bit executable support

     $ sudo yum install glibc.i686

2) atmod fails, missing 32 bit libstdc++.so.6

   Symptom:

   $ af90 t.f
    /opt/absoft11.5/bin/atmod: error while loading shared libraries:
    libstdc++.so.6: cannot open shared object file:
    No such file or directory

   Fix: Install 32 bit libstdc++.so.6

   $ sudo yum install libstdc++.i686

 3) Unable to execute projects inside AbsoftTools

    Symptom:

      An error dialog appears which reads "Could not start "xterm -name "Absoft Tools"... "

    Fix: install xterm program

      $ sudo yum install xterm
 
  4) Unable to build 32 bit programs

     Symptom:

      $ af90 -m32 t.f
      /usr/bin/ld: cannot find crt1.o: No such file or directory
      /usr/bin/ld: cannot find crti.o: No such file or directory
      /usr/bin/ld: skipping incompatible /usr/lib64/libpthread.so when
                    searching for -lpthread

     Fix: install 32 bit development libraries

      $ sudo yum install glibc-devel.i686
 

Open SuSE 12.1 64 bit

A default installation of Open SuSE 12.1 requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
gcc                                      Support for software development
gcc-c++                              Support for software development
gcc-32bit                             Support for building 32 bit programs
gcc-c++-32bit                     Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the zypper command to install the package.

1) Link fails, g++ not found

   Symptom:

    $ af90 t.f
    sh: g++: command not found
    link failed.

   Fix: install g++ (along with the rest of the C development tools)

    $ sudo zypper install gcc-c++

   Explanation:

      We use g++ to perform the link because AWE is written in C++.

2) Unable to build 32 bit programs

     Symptom:

      $ af90 -m32 t.f
        /usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld:
            skipping incompatible /usr/lib64/gcc/x86_64-suse-linux/4.6/../../../libpthread.so
            when searching for -lpthread

     Fix: install 32 bit development support

      $ sudo zypper install gcc-c++-32bit


Debian 6.0.3 64 bit

A default installation of 64 bit Debian 6.0.3 from the Debian GNOME Desktop"Live" DVD requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
lib32stdc++6                    Support for running 32 bit programs
gcc                                    Support for software development
g++                                  Support for software development
gcc-multilib                        Support for building 32 bit programs
g++-multilib                      Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) atmod fails, missing 32 bit libstdc++6

   Symptom:
     
     $ af90 t.f
       /opt/absoft11.5/bin/atmod: error while loading shared libraries:
       libstdc++.so.6: cannot open shared object file: No such file or directory
       atmod failed.
     
   Fix: install 32 bit libstdc++6

     $ sudo apt-get install lib32stdc++6
 
2) GCC/G++ and other development tools not installed

    Symptom:

      $ af90 t.f
      sh: as: command not found
      assembler failed.

      $ af90 t.f
      sh: g++: command not found
      link failed.

    Fix: Install GCC and C++ support

      $ sudo apt-get install gcc
      $ sudo apt-get install g++


3) Building 32 bit program fails

    Symptom:

     $ af90 -m32 t.f

    Fix: install 32 bit development support

     $ sudo apt-get install gcc-multilib
     $ sudo apt-get install g++-multilib
     

Ubuntu 12.04 64 bit

A default installation of Ubuntu 12.04 requires the following additional software to fully support Absoft Fortran 2012:

Package                            Description
----------------------       ---------------------------------------
ia32-libs                         Support for running 32 bit programs
gcc                                 Support for software development
g++                               Support for software development
gcc-multilib                      Support for building 32 bit programs
g++-multilib                      Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) Compiler front-end fails to load, no 32 bit executable support

   Symptom:
 
     $ af90 t.f
       sh: /opt/absoft11.5/bin/af90fe64: not found

   Fix: install 32 bit executable support

     $ sudo apt-get install ia32-libs

2) Link fails, g++ not found

   Symptom:

    $ af90 t.f
    sh: g++: not found
    link failed.

   Fix: install g++ (along with other C development tools)

    $ sudo apt-get install g++

   Explanation:

      We use g++ to perform the link because AWE is written in C++.

3) Building 32 bit program fails

    Symptom:

     $ af90 -m32 t.f
       /usr/bin/ld: cannot find crt1.o: No such file or directory
       /usr/bin/ld: cannot find crti.o: No such file or directory
       /usr/bin/ld: cannot find -lpthread

    Fix: install 32 bit development support

     $ sudo apt-get install gcc-multilib

Absoft User Forum  |  Archive  |  Linux Archive  |  Installing Absoft Pro Fortran 2012 (11.5) on 64 Bit Linux
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!