Absoft User Forum

Support => Building and Using Additional Software & Libraries => Topic started by: Thorsten on August 12, 2018, 04:08:06 AM

Title: Plplot latest version supported
Post by: Thorsten on August 12, 2018, 04:08:06 AM
Hi,
I wonder what is the latest version of plplot support by the absoft fortran 2018 compiler? I am on MacOS 13.13 and found that the latest absoft included version of plplot is 5.1 from 2003.
As plplot switched to full fortran 2013 their latest version 5.13 I could only compile with gfortran by the following terminal commands:
export FC="gfortran -O3"
cmake -DCMAKE_INSTALL_PREFIX=/opt/plplot --enable-shared=no ../
make
sudo make install
In case 5.1 is the last support version of plplot then is it possible to include the gfortran compiled librabries?

thx, Thorsten
Title: Re: Plplot latest version supported
Post by: forumadmin on August 13, 2018, 09:08:58 AM
PLPLOT  5.9.9 is included as part of the Absoft Additional Libraries package in Absoft Pro Fortran 2018.


The Absoft build is configured to use the X-Window drivers so you will also need to install the X11 server available from
https://www.xquartz.org/



Title: Re: Plplot latest version supported
Post by: Thorsten on August 16, 2018, 09:43:07 AM
Thanks, the functions in version 5.9.9. are so far sufficient. Are there any plans to include more drivers and an more current version in the next release of Absoft Fortran?