gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
1610 Posts in 533 Topics by 777 Members - Latest Member: machleid October 01, 2022, 04:30:51 AM
*
gfx* Home | Help | Search | Login | Register | gfx
gfx
Absoft User Forum  |  Archive  |  Linux Archive  |  Installing Absoft Pro Fortran 2017 (17.0) on 64 Bit Linux
gfx
gfxgfx
 

Author Topic: Installing Absoft Pro Fortran 2017 (17.0) on 64 Bit Linux  (Read 2587 times)

forumadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 332
Installing Absoft Pro Fortran 2017 (17.0) on 64 Bit Linux
« on: November 14, 2016, 08:42:20 AM »
This post addresses  issues encountered when installing Absoft Pro Fortran 2017 (v17.0) on the latest releases of the 64 Bit RedHat Enterprise Linux/Scientific Linux/CentOS, Fedora Core,  Open SuSE, Debian, and Ubuntu Linux distributions.


RedHat Enterprise Linux 7.2
RedHat Enterprise Linux 6.7
Scientific Linux 6.7
CentOS 6.7 (Final)

A default Software Development Workstation installation of RedHat Enterprise Linux/Scientific Linux/CentOS requires the following additional software to fully support Absoft Fortran 2017:

Package                         Description
----------------------         ---------------------------------------
gcc                                 Support for software development
gcc-c++                         Support for software development
glibc.i686                        Support for running 32 bit programs
libstdc++.i686                Support for running 32 bit programs
libpng12                         Graphics library used by AbsoftTools and Fx3 Debugger
xterm                             Terminal program used by AbsoftTools and Fx3 Debugger
glibc-devel.i686               Support for building 32 bit programs

                       
Examples below give a possible error messages reported when a package is missing and the yum command to install the package.

1) Compiler front-end fails to run, no 32 bit executable support

   Symptom:
   
     $ af90 t.f
        sh: /opt/absoft17.0/bin/af90fe64: /lib/ld-linux.so.2: bad ELF interpreter:
           No such file or directory
        f90fe failed.

   Fix: Install 32 bit executable support

     $ sudo yum install glibc.i686

2) atmod fails, missing 32 bit libstdc++.so.6

   Symptom:

   $ af90 t.f
    /opt/absoft17.0/bin/atmod: error while loading shared libraries:
    libstdc++.so.6: cannot open shared object file:
    No such file or directory

   Fix: Install 32 bit libstdc++.so.6

   $ sudo yum install libstdc++.i686

3) GCC/G++ and other development tools not installed

    Symptom:

      $ af90 t.f
        sh: as: command not found
        assembler failed.
      $ af90 t.f
        sh: g++: command not found
        link failed.

    Fix: Install GCC and C++ support       
       $  sudo yum install  gcc-c++

4) AbsoftTools and Fx3 fail to load, missing libpng12.so.0

   Symptom:
     $ Fx3
     /opt/absoft17.0/bin/Fx3_bin: error while loading shared libraries:
     libpng12.so.0: cannot open shared object file:
     No such file or directory

     $ atools

     /opt/absoft17.0/bin/atools_bin: error while loading shared libraries:
     libpng12.so.0: cannot open shared object file:
     No such file or directory

   Fix: Install libpng12
      $ sudo yum install libpng12.x86_64

5) Unable to execute projects inside AbsoftTools

    Symptom:

      An error dialog appears which reads "Could not start "xterm -name "Absoft Tools"... "

    Fix: install xterm program

      $ sudo yum install xterm
 
6) Unable to build 32 bit programs

     Symptom:

      $ af90 -m32 t.f
      /usr/bin/ld: cannot find crt1.o: No such file or directory
      /usr/bin/ld: cannot find crti.o: No such file or directory
      /usr/bin/ld: skipping incompatible /usr/lib64/libpthread.so when
                    searching for -lpthread

     Fix: install 32 bit development libraries

      $ sudo yum install glibc-devel.i686


Fedora Core 25 64 bit

A default installation of Fedora Core 25 Workstation requires the following additional software to fully support Absoft Fortran 2017:

Package                       Description
----------------------       ---------------------------------------
glibc.i686                     Support for running 32 bit programs
libstdc++.i686             Support for running 32 bit programs
gcc                              Support for software development
gcc-c++                      Support for software development
libpng12                      Graphics library for AbsoftTools and Fx3 Debugger
xterm                          Terminal program used by AbsoftTools and Fx3 Debugger
ncurses-compat-libs.x86_64    Support for 64 bit Fx3 Debugger
glibc-devel.i686            Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the dnf command to install the package.

1) 32 bit executable support not installed

  Symptom:

     $ af90 t.f
        sh: /opt/absoft17.0/bin/af90fe64: /lib/ld-linux.so.2: bad ELF interpreter:
             No such file or directory       
        f90fe failed.   

   Fix: install 32 bit glibc
      $ sudo dnf install glibc.i686

2) 32 bit libstdc++.so.6 not installed

   Symptom:

      $ af90 t.f
        /opt/absoft17.0/bin/atmod: error while loading shared libraries: libstdc++.so.6:
            cannot open shared object file: No such file or directory
        atmod failed.

   Fix: install 32 bit libstdc++.so.6
      $ sudo dnf install libstdc++.i686

3) GCC/G++ and other development tools not installed

    Symptom:

      $ af90 t.f
        sh: as: command not found
        assembler failed.
      $ af90 t.f
        sh: g++: command not found
        link failed.

    Fix: Install GCC and C++ support       
       $  sudo dnf install  gcc
       $  sudo dnf install  gcc-c++

4) Unable to launch AbsoftTools and Fx3
    Symptom:

      $ atools         
          /opt/absoft17.0/bin/atools_bin: error while loading shared libraries: libpng12.so.0:
          cannot open shared object file: No such file or directory
      $ Fx3
          /opt/absoft17.0/bin/Fx3_bin: error while loading shared libraries: libpng12.so.0:
          cannot open shared object file: No such file or directory

    Fix: Install libpng12 package
       $  sudo dnf install libpng12

5) Unable to execute projects inside AbsoftTools

    Symptom:

      An error dialog appears which reads "Could not start "xterm -name "Absoft Tools"... "

   Fix: install xterm program
      $ sudo dnf install xterm

6) Unable to build 32 bit programs

    Symptom:

      $ af90 -m32 t.f
       /usr/bin/ld: cannot find crt1.o: No such file or directory
       /usr/bin/ld: cannot find crti.o: No such file or directory
       /usr/bin/ld: skipping incompatible /usr/lib64/libpthread.so when
                     searching for -lpthread     

     Fix: install 32 bit development libraries
        $ sudo dnf install glibc-devel.i686

7) Fx3 Debugger fails loading 64 bit program

       Symptom:  Lost connection with Fx3 debugger backend dialog
                           or running fx3_64 from the command line gives:

        $ fx3_64
           /opt/absoft17.0/bin/fx3_64bin: error while loading shared libraries:
           libncurses.so.5: cannot open shared object file: No such file or directory

       Fix: Install 64 bit ncurses compatibility package

         $ sudo dnf install ncurses-compat-libs.x86_64
       

Open SuSE 12.2
Open SuSE 13.1
Open SuSE Leap 42 64 bit

A default installation of Open SuSE 12.2, 13.1, or Leap 42 requires the following additional software to fully support Absoft Fortran 2017:

Package                            Description
----------------------         ---------------------------------------
libstdc++47-32bit         Support for running 32 bit programs
gcc                                Support for software development
gcc-c++                        Support for software development
libpng12-0                     Graphics library used by AbsoftTools and Fx3 Debugger
gcc-32bit                       Support for building 32 bit programs
gcc-c++-32bit               Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the zypper command to install the package.

1) 32 bit libstdc++.so.6 not installed

   Symptom:

     $ af90 t.f
        /opt/absoft17.0/bin/atmod: error while loading shared libraries:
        libstdc++.so.6: cannot open shared object file: No such file or directory
        atmod failed.

   Fix: install 32 bit libstdc++.so.6

     $ sudo zypper install  libstdc++47-32bit

2) Compilation fails, as/g++ not found

   Symptom:

     $ af90 t.f
      sh: as: command not found
     assembler failed.

     $ af90 t.f
      sh: g++: command not found
      link failed.

   Fix: install g++ (along with the rest of the C development tools)

    $ sudo zypper install gcc-c++

3) Unable to launch AbsoftTools and Fx3

   Symptom:
     $ atools
       /opt/absoft17.0/bin/atools_bin: error while loading shared libraries:
       libpng12.so.0: cannot open shared object file: No such file or directory

     $ Fx3
        /opt/absoft17.0/bin/Fx3_bin: error while loading shared libraries:
        libpng12.so.0: cannot open shared object file: No such file or directory

   Fix: Install libpng12-0

     $  sudo zypper install libpng12-0

4) Unable to build 32 bit programs

   Symptom:

     $ af90 -m32 t.f
        /usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld:
        skipping incompatible /usr/lib64/gcc/x86_64-suse-linux/4.6/../../../libpthread.so
        when searching for -lpthread

   Fix: install 32 bit development support

     $ sudo zypper install gcc-c++-32bit

Debian 6.0.6
Debian 7.2.0
Debian 8.2.0
A default installation of 64 bit Debian 6.0.6,7.2.0 or 8.2.0  from Debian Desktop "Live" DVD requires the following additional software to fully support Absoft Fortran 2017:


Package                            Description
----------------------       ---------------------------------------
lib32stdc++6                    Support for running 32 bit programs
gcc                                    Support for software development
g++                                  Support for software development
gcc-multilib                        Support for building 32 bit programs
g++-multilib                      Support for building 32 bit programs

Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) atmod fails, missing 32 bit libstdc++6

   Symptom:

     $ af90 t.f
       /opt/absoft17.0/bin/atmod: error while loading shared libraries:
       libstdc++.so.6: cannot open shared object file: No suach file or directory
       atmod failed.

   Fix: install 32 bit libstdc++6

     $ sudo apt-get install lib32stdc++6

2) GCC/G++ and other development tools not installed

    Symptom:

      $ af90 t.f
      sh: as: command not found
      assembler failed.

      $ af90 t.f
      sh: g++: command not found
      link failed.

    Fix: Install GCC and C++ support

      $ sudo apt-get install gcc
      $ sudo apt-get install g++


3) Building 32 bit program fails

    Symptom:

     $ af90 -m32 t.f

    Fix: install 32 bit development support

     $ sudo apt-get install gcc-multilib
     $ sudo apt-get install g++-multilib


Ubuntu 16.10
Ubuntu 15.10

A default installation of Ubuntu 16.10 or 15.10 requires the following additional software to fully support Absoft Fortran 2017:

Package                            Description
----------------------       ---------------------------------------
libc:i386                         Support for running 32 bit programs
libstdc++6:i386             Support for running 32 bit programs
gcc                                 Support for software development
g++                               Support for software development


Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) Compiler front-end fails to load, no 32 bit executable support

   Symptom:

     $ af90 t.f
       sh: /opt/absoft17.0/bin/af90fe64: not found

   Fix: install 32 bit executable support

     $ sudo dpkg --add-architecture i386
     $ sudo apt-get update
     $ sudo apt-get install libc6:i386
     $ sudo apt-get install libstdc++6:i386

2) Link fails, g++ not found

   Symptom:

    $ af90 t.f
    sh: g++: not found
    link failed.

   Fix: install g++ (along with other C development tools)

    $ sudo apt-get install g++


Ubuntu 12.04
Ubuntu 13.04


A default installation of Ubuntu 12.04 or 13.04 requires the following additional software to fully support Absoft Fortran 2017:

Package                            Description
----------------------       ---------------------------------------
ia32-libs                         Support for running 32 bit programs
gcc                                 Support for software development
g++                               Support for software development
gcc-multilib                     Support for building 32 bit programs
g++-multilib                   Support for building 32 bit programs


Examples below give a possible error messages reported when a package is missing and the apt-get command to install the package.

1) Compiler front-end fails to load, no 32 bit executable support

   Symptom:

     $ af90 t.f
       sh: /opt/absoft17.0/bin/af90fe64: not found

   Fix: install 32 bit executable support

     $ sudo apt-get install ia32-libs

   Alternate Fix: install minimum 32 bit executable support

     $ sudo apt-get install libc6-i386
     $ sudo apt-get install lib32stdc++6

2) Link fails, g++ not found

   Symptom:

    $ af90 t.f
    sh: g++: not found
    link failed.

   Fix: install g++ (along with other C development tools)

    $ sudo apt-get install g++

3) Building 32 bit program fails

    Symptom:

     $ af90 -m32 t.f
       /usr/bin/ld: cannot find crt1.o: No such file or directory
       /usr/bin/ld: cannot find crti.o: No such file or directory
       /usr/bin/ld: cannot find -lpthread

    Fix: install 32 bit development support

     $ sudo apt-get install gcc-multilib

Absoft User Forum  |  Archive  |  Linux Archive  |  Installing Absoft Pro Fortran 2017 (17.0) on 64 Bit Linux
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!