gfxgfx
 
Please login or register.

Login with username, password and session length
 
gfx gfx
gfx
1514 Posts in 501 Topics by 731 Members - Latest Member: agoodcave September 25, 2020, 02:39:30 PM
*
gfx* Home | Help | Search | Login | Register | gfx
gfx
Absoft User Forum  |  Support  |  Linux  |  Library Path
gfx
gfxgfx
 

Author Topic: Library Path  (Read 75 times)

tcusan

  • Newbie
  • *
  • Posts: 4
Library Path
« on: September 16, 2020, 08:23:35 AM »
The line in abvars.sh that sets the LD_LIBRARY_PATH is causing a conflict with some of the other software running on my server such as emacs. As a result, emacs is incorrectly loading the absoft version of libexpat.so.1 instead of the copy that's located in the /usr/lib64 directory, which results in a bunch of error messages. I was able to resolve this issue by updating the LD_LIBRARY_PATH to remove the paths set by absoft. However, this is not an ideal solution in regards to the compiler. I was wondering if there is a better way to resolve this conflict without having to remove the absoft-specific paths.

Thanks!

forumadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 304
Re: Library Path
« Reply #1 on: September 16, 2020, 09:45:01 AM »
You did not mention which version of Absoft Pro Fortran for Linux you are using, but for 64-bit Absoft Pro Fortran 18.0 and earlier, you can resolve this issue by moving the three expat related files libexpat.so, libexpat.so.1, libexpat.so.1.5.0 from  /opt/absoftXX.X/shlib64 to /opt/absoftXX.X/qtshlib.
 
   cd /opt/absoftXX.X/shlib64
   sudo mv libexpat.so ../qtshlib
   sudo mv libexpat.so.1 ../qtshlib
   sudo mv libexpat.so.1.5.0 ../qtshlib


(replace XX.X which the digits for your version)

This will not affect the operation of the compiler at all and the AbsoftTools and Fx3 applications which use Qt will find the  expat shared library in the new location.
« Last Edit: September 16, 2020, 12:05:25 PM by forumadmin »

tcusan

  • Newbie
  • *
  • Posts: 4
Re: Library Path
« Reply #2 on: September 16, 2020, 11:57:57 AM »
I'm using version 17.0. This seems to have fixed the problem. Thank you very much!

Absoft User Forum  |  Support  |  Linux  |  Library Path
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!